Home

I can no longet see any images in my emails from Road.cc. Clicking the 'Not Displaying?' link takes me to a wev page where the images still don't display.

Am I alone?

 

 

9 comments

Avatar
TheBillder [45 posts] 1 month ago
0 likes

You might be, I can see them. Depends greatly on what you use for mail (browser, phone app, Outlook etc) and how things are set up.

If you're in a corporate environment, road.cc might not be seen as a trusted domain and it's fairly common for images to be blocked as a security measure. But many mail programs would make it clear that that had happened.

Avatar
centurion48 [15 posts] 1 month ago
0 likes

No images for me either. I am using Apple Mail as my email app. It was fine until a month or so ago then no images. It is only email from road.cc that is affected.

Hopefully a problem that will resolve itself in time.

Avatar
andsaw [41 posts] 1 month ago
0 likes

Happens to me as well, no restrictions and im on outlook standard.

Avatar
matthewn5 [1420 posts] 1 month ago
0 likes

Yeah, I can't see images either, not in apple's Mail client nor when I log in directly to Outlook. I thought it was just me.

Avatar
Roughie [1 post] 1 month ago
0 likes

Same problem here with Outlook ...Ran the big  update for Windows 10 recently and have had lots of problems since including this one ...But as its only the thumbnail's i dont think it matters that much .

 

Avatar
Tony Farrelly [3004 posts] 1 month ago
0 likes

Hi all, 
Thanks for flagging this up, we had some emails about it too.

We're looking in to it but to be honest at this stage we're not actually sure what is causing it - we haven't changed anything about the way we produce the newsletters. Also we're having a problem replicating the issue in full on different browsers - someon forwarded Friday's newsletter which they couldn't see any pics in and we could in both Gmail and Apple Mail. That said, the images in the header bar didn't display properly in the actual newsletter the system sent me - although all the pics displayed fine…

If you do have the issue again it would be useful to know what mail client you were using and on what type of device. 

Avatar
matthewn5 [1420 posts] 4 weeks ago
0 likes

Yes still having this problem, in Apple Mail 11.5 on a Macbook Pro running OSX 10.13.6.

Also when logging into Outlook.com on Firefox 69.0.3 (64-bit), and on Safari 13.0.2.

I use Adblock but have whitelisted road.cc and turned off Firefox's inbuilt blocking.

Avatar
Moisha [2 posts] 4 weeks ago
0 likes

Same problem here. For both road and off road newsletters. I also use Apple mail and haven't changed anything my end. Started about three weeks ago. Wonder if it could be an iPhone update causing the problem? 

Avatar
torquerulesok [28 posts] 3 weeks ago
0 likes

Same here: no images displayed in Apple Mail or using the “Not displaying? Click here”  link to view in Safari. Same across all my Apple devices. Definitely a road.cc problem only. Every other email and website work fine.

 

Two positive side effects:

1. I waste no time clicking on ads.

2. I now spend almost no time on the road.cc website.

 

As an advertiser that would worry me. There must be tens of thousands of clicks lost and that’s what advertisers are paying for. Maybe once the website traffic falls off enough, the road.cc coders will pull their finger out and fix this .