wireless cateye strada 'freezing'

by Adey   July 15, 2013  

Hi all
owned the cateye strada 'wireless' with cadence for 2 months now, bought 2nd hand from another clubrider and overall very pleased with the product....until my last 2 rides, problem is its 'froze' or 'crashed' halfway round my rides.
Apart from the inconvenience of re setting the computer, all your mileage/data is lost Sad
The batteries were brand new (replaced when bought)when i took ownership, also the unit 'vibrates/rattles' like 'bloody hell'!! Angry could this contribute towards the 'freezing'?
Anyone else had this problem?
Cheers Ade

4 user comments

Oldest firstNewest firstBest rated

Buy a garmin

posted by Shanefutcher [120 posts]
15th July 2013 - 22:14

2 Likes

No, I've never had this problem with the Cateye wireless.

When you say the "unit" rattles, do you mean the sensor on the chainstay or the display on the stem? I've never had any rattle from either, but I can't imagine that rattling will help the wireless transmission between sensor and unit.

Perhaps try taking the whole lot off the bike and then reinstalling, making sure that the sensor, unit and magnets are tightly fixed.

posted by Sadly Biggins [266 posts]
16th July 2013 - 13:59

1 Like

I had one of these a while back, I don't remember clearly but I do vaguely remember the head unit used to rattle and I think I solved it by putting some electrical tape into the mount so it was a bit of a tighter fit. Never had any issues with it freezing though

posted by pirnie [197 posts]
16th July 2013 - 14:08

2 Likes

cheers for taking the time Sads and Pirnie - will try the tape trick
shanefutcher feckoff!! Big Grin

posted by Adey [98 posts]
18th July 2013 - 20:06

2 Likes