Garmin Edge 500 Upgrade Issues

by cautrey01   June 3, 2012  

I'm having a nightmare getting my Edge 500 to work after trying to upgrade to the new verison 3.0 firmware. Anyone else having problems? Angry

7 user comments

Oldest firstNewest firstBest rated

Whats the actual prob?

Sir Velo

Raleigh's picture

posted by Raleigh [1733 posts]
3rd June 2012 - 22:09

0 Likes

1st time I tried to upgrade, the unit froze at startup displaying the 'Software Missing' message which required special sfw sent by Garmin suport to fix - this defaulted the unit back to version 2.3. Every new attempt to upgrade freezes the unit with Loader Loading message. Quite a few people are reporting issues on Garmin forum.

posted by cautrey01 [4 posts]
3rd June 2012 - 22:24

0 Likes

2.3's fine though isn't it?

I don't notice huge elevation differences to reality, and I don't use a power meter or 'workouts,' either.

What other new things have they added to the new update?

Sir Velo

Raleigh's picture

posted by Raleigh [1733 posts]
3rd June 2012 - 22:40

0 Likes

Raleigh wrote:
2.3's fine though isn't it?

I don't notice huge elevation differences to reality, and I don't use a power meter or 'workouts,' either.

What other new things have they added to the new update?

There have been many releases since version 23 to address many issues as the product has evolved. Are you using 2.3 now and you seeing any issues?

posted by cautrey01 [4 posts]
3rd June 2012 - 22:50

0 Likes

i had probs with the update,i had to delete 2 course on the unit and a garmin fit file which has sorted thank god Big Grin

Experience is how life catches up with us and teaches us to love and forgive each other

RobeH's picture

posted by RobeH [35 posts]
11th June 2012 - 19:03

0 Likes

Yep.

Spent a lot of time on the phone today with some very helpful people at Garmin and mine's off in the post tomorrow to them.

My problem was that I didn't wait long enough after downloading the firmware upgrade (bored waiting, no message on the screen), then got the missing software message and nothing else. Completely dead. Sad

posted by Bagpuss [102 posts]
12th June 2012 - 20:09

0 Likes

Cool Love the g-10,have had it one year,no problems with update,works fine.
However,my specialized Robaix chainstays take a sharp turn inward,away from crank arm about 2 inches from bottom bracket,I had to fashion a 1/2 inch block of wood,
fasten it to the crank arm then mount the magnet on it to get close enough to the g-10 to activate it and keep it working.
I would have thought Garmin would have addressed this situation, Anyone else with a Robaix,use this solution.

posted by dennis2424 [1 posts]
18th August 2012 - 13:53

0 Likes