Tacx Flow turbo trainer - broken

by one_bad_mofo   May 6, 2012  

I have a Tacx FLow turbo trainer that is less than five months old. While using it this morning (couldn't face going out riding in the rain) the control screen went blank. Now the resistance is stuck on maximum and I can't get any information on the screen or change any of the settings.
Has ayone had a similar problem or know of any solution? I 've contacted teh retailer to ask for a replacement but I don't know how long that will take. Thinking

4 user comments

Oldest firstNewest firstBest rated

Presuming you're in the UK it shouldn't be too long as both the 2012 non VR and VR are in stock with the UK distributor. TACX have a diagnostic help page on their website. http://www.tacx.com/en/service/diagnostic_tool.dot

Wooliferkins's picture

posted by Wooliferkins [47 posts]
6th May 2012 - 10:41

like this
Like (2)

Thanks for that but the trainer isn't connected to a PC, so I doubt the diagnostics would help.

The other issue is that the retailer is no longer showing the model of trainer I have as being available! As it was I got a deal on the Flow because the Satori Pro I originally bought had pieces missing when I got it home and unpacked it and was the last one in stock so I got a discount upgrade on the Flow.

posted by one_bad_mofo [31 posts]
6th May 2012 - 11:12

like this
Like (2)

I had the same problem with a Tacx VR motor unit - seized completely. I just took it in to my local bike shop who are tacx dealers who then sent it off for me for a replacement. Took a couple of weeks

posted by spxxky [3 posts]
11th May 2012 - 13:41

like this
Like (2)

I guess I was lucky. I took the trainer back this week and had it swapped for a new one. Big Grin

posted by one_bad_mofo [31 posts]
11th May 2012 - 14:30

like this
Like (2)