garmin edge 800 - syncing problems

by richcrocker79   March 16, 2014  

I recently bought an edge 800, and I love it.

I've used it a dozen or so times, and sync to strava and garmin connect, but now it will not sync via usb at all.

It receives power over the usb as it charges when it is plugged in, but it doesn't get recognised as anything at all, via strava, garmin connect, or as an external drive?

Can anybody offer any insight? if it makes any difference i'm pugging in to a macbook, and all the software etc is up to date?

Thanks for any help!

Rich

10 user comments

Oldest firstNewest firstBest rated

I gave up using the auto link software and now upload each file manually. Strata has a facility to upload from a file and just click on that and find the fit file on the Garmin file directory

posted by arfa [542 posts]
16th March 2014 - 15:57

3 Likes

I sometimes find that if i haven't been ejecting it properly then it doesn't get recognised, solution for that is the obvious restart. But if you have done that already then no idea!

posted by tommygarland [17 posts]
16th March 2014 - 16:25

2 Likes

Have you tried using the new Garmin Express? I'm quite impressed with it.

Have you tried it on a different machine/with a different USB cable?

posted by n8udd [17 posts]
16th March 2014 - 17:10

2 Likes

Make sure you use the Garmin USB cable, my 200 will only sync with the genuine Garmin cable.

posted by Sevenfold [31 posts]
16th March 2014 - 19:58

3 Likes

thanks for you responses, i did some more googling, and on some of the older models people talk of pushing buttons and touching screens, so with a bit of trial and error, and I found that if i press the start/stop button when its plugged in via the usb, all of a sudden it all works - I'm sure that never was the case the first dozen times i used it, but hey ho, at least all is well.

I've changed it to store everything on removable media too, so as area says at least if there are any there problems, I can still upload manually!

thanks again!

posted by richcrocker79 [7 posts]
17th March 2014 - 1:53

2 Likes

I have an edge 500 that's seen better days, quite regularly refuses to be recognised by any computer or cable. Turns out moisture ingress seems to be the issue for me. A tiny drop of WD-40 in the access port every so often seems to do the trick.

posted by Ropedoctor [19 posts]
17th March 2014 - 10:22

3 Likes

I too have been having trouble with my Garmin Edge 800 and Garmin Forerunner 910XT since Garmin updated their software for Macs. I found that I had to unpair & re-pair the Bluetooth connection/ANT stick for the Forerunner but that the Edge 800 works OK with the new Garmin Express software.
Like others, I have has issues with third-party software (Runkkeper, MapmyRide, RideWithGPS & Strava). I now export the .tcx from Garmin Connect and import the file into these applications.
It used to be so easy, which is why Garmin probably changed it.

posted by centurion48 [13 posts]
17th March 2014 - 22:25

2 Likes

Have you set it to record activities on the SD card rather than the internal, if so Strava won't find them and you'll need to manual upload.
If your PC isn't seeing the device at all, first change which USB socket you are plugging in to, your OS will consider it a new device, if that fails try another cable.

posted by Notsofast [49 posts]
18th March 2014 - 10:32

1 Like

I had a unique problem with my Garmin 800. Every time I tried an upload it would eject the thing. Then my girlfriend bought a Bryton and eventually she started having the same problem. Turns out the problem was to do with my Suunto Movescount. So I would suggest you check what software is automatically opening and make sure there are no conflicts. Also, make sure you eject the Garmin properly.

posted by Colin Peyresourde [1205 posts]
19th March 2014 - 0:31

1 Like

Likewise here with my 500. GT85 in the port sometimes improves things.

I had Finder open a week or so ago and while the Garmin was charging and obviously receiving power, it wasn't showing as a removable disk. So I couldn't manually access files either.

Now I open Finder, and make sure I can see it whilst I open Strava or Garmin Connect. After a few minutes, usually the disk logo appears. Then it's all fine to upload. No idea why this delay happens but just watching for that logo appear has saved me all sorts of frustration of ejecting/reconnecting/swearing etc. Maybe this might work for you...

posted by andyp [1075 posts]
19th March 2014 - 8:32

1 Like